The!Cart Studio

Welcome to "The!Cart Studio", the free cartridge image authoring tool for The!Cart , Atarimax Maxflash Cartridges and free-style binary cartridge images. The program enables you to create workbooks for cartridge images which contain one or more ROMs or executables. The workbook an then be exported in different formats. Besides plain binary images for usage if an EPROM or external flash programming device, emulator cartridge images to run the cartridge in emulators and flash programming disk images which can be booted or loaded directly from the Atari to flash the target flash module. You need a device and software that is capable of transferring the data from your PC to the Atari like for example SIO2PC (available here and here ) with AspeQt or SIO2SD . For "The!Cart", you do not need a USB programmer device or other PC related hardware for programming. Because "The!Cart Studio"" can also create plain binary export files for a workbook, you can of course also use an USB programmer device to burn or flash them into any kind of cartridge supported by the device.

Sequence for creating workbooks and tranferring them to the cartridge

You can watch the youtube video presentation get an idea how it works and looks like. To really learn about the details and features you should carefully read this English manual. The German manual is under construction and will provided completely once the English manual is complete. If you have question regarding "The!Cart" or "The!Cart Studio", you can contact me directly or post in the "The!Cart" thread on AtariAge (English) or in the ABBUC Forum (German) .

Downloading the Program

This is version ${version} of the program. Click here to download the latest version of the program. The download is a single ".zip" archive file which contains the actual program plus additional operating system specific wrapper files. Simply extract the files from the archive into a folder of your choice.

Download archive content

Starting the Program

"The!Cart Studio" is implemented in Java which makes is compatible with all popular operating systems. In order to run the program you need has Java Runtime Environment (JRE) or Java Development Kit (JDK/SDK) with version 1.6 or newer versions installed. Using Java 1.7 is recommended because on the one hand Java 1.6 is out of maintenance and on the other hand, multi-selection in the file selection dialog will only work with JDK 1.7 or newer versions. "The!Cart Studio" requires enough RAM available for the Java process to be able to export images. The amount of available RAM is display in the "About" dialog. It should be twice the size of the cartridge you want to export. So for a 128 MB "The!Cart" export, the program requires at least 256 MB. You can specify this when you start from the command line via "java -Xmx256M -jar TheCartStudio.jar". By default "The!Cart Studio" check if an update is available during the start. The check is performed in the background and has no impact on the startup time. You can disable this check in the options.

Windows

Double-click "TheCartStudio.exe" to start the program. The "TheCartStudio.jar" file with the actual program must be present in the same folder. Alternatively you can run the program also from the command prompt ("cmd.exe"). In this case you can change the current path to the folder where "TheCartStudio.jar" is located and type "java.exe -jar TheCartStudio.jar" to start the graphical user internal. Alternatively the following parameters are supported when running from the command line.

Starting in Windows command prompt

Linux

After extracting the "TheCartStudio.sh" and the "TheCartStudio.jar" file from the download archive, the so called "executable bit" is not set, resulting in the following error message when you double-click on of the files.

After unpacking

Open the file properties, set the executable flag as shown below for both files. The installation of the Java runtime normally registers itself as the default application for the file extension ".jar". So by simply double-clicking the "TheCartStudio.jar" file or by choosing "Open" from the context menu, the program should start. If that is not the case or if you get error messages reporting that there is not enough memory reserved for Java, you can double-lick the "TheCartStudio.sh" instead.
Please note that there is a known bug in Ubuntu , for example 12.10 with openjdk7. It is tracked as "Unreadable menu bar with Ambiance theme in Java/Swing GTK L&F" and causes the menu to appear too dark; making is barely readable with the standard desktop theme. Changing the desktop theme fixes this.

Setting the executable bit

MacOSX

This is currently procedure same as for Linux, except that Java 1.6 is available by default in Mac OS X 10.9 "Mavericks". The amount of memory available to Java by default appears to be 128 MB. Consequently it is mandatory to start "The!Cart Studio" using "TheCartStudio.sh" to reserve enough RAM for exporting a 128 MB cartridge. A first native app version "TheCartStudio.app" is also included in the download. Currently it is completely untested as I do not have a Mac OS X machine and so will probably not work yet.

General Usage

The "The!Cart" enables you to create workbooks for cartridge images which contain one or more ROMs or executables. The workbook an then be exported in different formats. Besides plain binary images (".BIN", ".ROM") for usage if an EPROM or external flash programming device, emulator cartridge images (".CAR") to run the cartridge in emulators and flash programming images (".ATR") which can be booted or loaded directly from the Atari to flash the target flash module. Depending on the disk emulation you are using, you can export the workbook a single large programming disk image for use with AspeQt or as multiple 16 MB sized programming disk images for use with SIO2SD , SIO2USB or similar SIO device emulators. You can also export cartridge images in plain binary (".BIN") to burn or flash them to any kind of cartridge using a programmer device.

Detailed sequence for creating workbooks and tranferring them to the cartridge

In case you are creating workbooks for "The!Cart", you can make use of the native cartridge emulation feature and reuse the existing software for "Atari Maxflash Cardridges" and "MegaCart cartridges". This means you can one the one hand directly use existing compilations and just add them as a single file. On the other hand you can use Maxflash Studio and MegaCart Studio to create new compilations and images for these cartridges and then add them as a single file. Because the Extended Menu of "The!Cart" also recognizes the menu systems of these two cartridge systems, it can optionally offer you the entries within these menus directly.

Detailed sequence for creating workbooks and tranferring them to the cartridge

Using the different studios with their specific loaders can be useful in particular when adding ATR disk images. It is in the nature or ROM cartridges that no 100% emulation of standard disk handling is possible. Any kind of ATR emulation must use at least a little amount of the computer's RAM. And if a certain program uses this RAM area while loading from the cartridge, the loader will be overwritten and crash. The details on the different methods used can be found in the section ATR Disk Images . The following table given an overview of the features supported by the individual loaders. With this information you can decide which loader might be the right one for you.

Loader Method Compatible with Programs using the RAM under the OS Supports Disk Swapping Supports Poke and Patches
Maxflash Studio Modified Atari OS in RAM No No No
MegaCart Studio Modified Atari OS in RAM No Yes No
The!Cart Studio Modified ATR Image Yes No (planned) Yes

User Interface

The user interface of "The!Cart Studio" is localized and current comes with English and German screen texts. You can change the display language via the menu entry "Tools/Options...". The default value is "Automatic", which means that the language is determined automatically based on the language settings of the operating system.

Options

By default, only the most frequently used columns are display in the various tables. You drag & drop to change the order of the columns. Clicking on column header with SHIFT or CONTROL held down extends the sort order by appending this column. This way you can sort by genre first and then by title for example. Clicking a column header without pressing SHIFT or CONTROL resets the sort order to that single column. You can also use the context menu to hide visible columns, unhide invisible columns and reset visibility and sort order to the default. All layout changes are saved automatically when the program is closed. This also applies to the size and the position of the main window and to the different folders that were last used for loading/saving workbooks, adding entries and exporting cartridge images.

Workbook entries table header context menu

All relevant commands also have a key binding, so you can use your keyboard to fully control the program.

Creating Workbooks

In the "File" menu you can find the usual "New", "Open", Save", "Save As" and "Close" actions. When "The!Cart Studio" is opened, a new unnamed project is already prepared. You can display the dialog to edit the workbook options via the menu entry "Edit/Workbook Options...".
Workbook options

Adding Entries

You can add files for new entries via the menu entry "Edit/Add Entries...". The file chooser has multi-selection enabled, that means you can select multiple files at once and add them in go. Alternatively you can use drag & drop to drop one or multiple files onto the window to add entries.

Selecting one or more files to add

"The!Cart Studio" contains a database of popular ROMs and will assign the correct title automatically based on size and the CRC32 checksum of the file. If no matching entry is found in the data, the title of the entry is defaulted from the file name by removing the file extension.

When new files are added, they remain at their original location first. When you save the workbook, all newly added files will be copied into the data folder (".tcd") of the workbook. This way you have all files and the workbook together in one location. As a consequence, a file in the workbook is uniquely identified by its case-insensitive file name, irrespective of the folder it was originally copied from. Adding files with the same file name will result in a confirmation dialog where you can choose to overwrite the existing file in the data folder with the new file, rename the file automatically during copying or to skip the new file, leaving the existing file in the data folder unchanged. The choice can either be applied to the current file only or to the current file and all following files.

Confirm overwriting an existing file

Entry Properties

The information for every entry is displayed in the columns of table on the "Entries" tab". Only the most important columns are visible by default. They are show with bold names on the table. You can configure the visibility and order of the columns as described in the section General Usage . Columns listed as editable can be read-only for certain entries depending on the type of the entry or other conditions.

Column Editable Description
Line No The line number in the table.
Type No The type of the entry. Possible values are:
  • File
    This entry was added via the standard "Add Entries..." action by selecting a file that is now part of the workbook. The entry and content of the file will be exported when the workbook is exported.
  • User Space
    This entry was added via the "Add User Space Entry..." action by selecting a file that is now part of the workbook. User space entries can only be added if user space is reserved in the workbook options. A user space entry is exported as menu entry only and points to a bank in the User Space that is not maintained from from "The!Cart Studio".
Title Yes The title of the entry in the extended menu. It must be specified and should unique within the workbook because it is the basis for the search in the extended menu. The length of the title is limited to 40 characters and to characters that actually exist in the Atari's character set. The title is defaulted when the entry is added based on built-in the cartridge database. If no entry can be found in the database, the title is defaulted based on the name of the newly added file.
Genre Yes The genre of the entry. Genres like "Games", "Demos" or "Tools" can be defined in the workbook options. Every entry can optionally be assigned to a genre. There are three way to do this. First by typing in the name of the genre with the keyboard. Second by choosing the genre from the drop down list of the field. Third by the action "Set Genre..." in the "Edit" menu. Using the "Set Genre..." action, you can set or clear the genre for all selected entries at once. If an entry not assigned to a genre, is will only be present on the "All" tab of the extended menu. If a type is assigned to a genre, it will be present on the "All" tab and on the tab for the genere.
Favorite Yes The favorite indicator is currently not used by the extended menu. It is planned to be used as additional filter in the future. The idea is that if you set the favorite indicator for an entry, the initial list of entries in the extended menu only shows the favorites. This way you can use the joystick or cursor key to select from restricted list of entries. As soon as you start typing a search term, the favorite indicator become irrelevant and all entries are searched.
File Path No The source file path for newly added and not yet saved entries. Once the workbook is saved, the file will be copied from the source file path into the data folder of the wookbook and the file path will be cleared.
File Name No The file name of the entry that uniquely identifies the entry within the wookbook and the data folder of the workbook.
File Size No The exact file size of the file in bytes.
File Header No The file header type of the file. Possible values are:
  • None
    The file does not have a specific file header that describes its content. The complete file content is considered as relevant data for "The!Cart". You have to select the proper content type manually.
  • Cartridge
    The file is a ".car" file that contains an additional header that describes is content. Only the part of the file after the header is considered as relevant for "The!Cart". The content type of the entry is set automatically and cannot be changed manually.
Content Size No The size of the relevant content in the file. For files with header type "None", it is equal to the file size. For files with another header type, it is the file size minus the size of the header.
Content CRC32 No The CRC32 checksum of the content. This checksum is used as identification to find information in the cartridge database. You will sometime also find this checksum when people try to identify which ROM or version of a ROM they have.
Content Type Yes The content type of the entry. The content type controls how "The!Cart" and the extended menu interpret the binary content behind the entry. To start an entry correctly, the correct content type must be set. If you add entries with a "Cartridge" file header, the content type is determined automatically and cannot be changed manually. If you add a plain binary file, "The!Cart Studio" will default the content type is possible based on the size of the file. If there is more than one content type that matches the file size, you have to select the correct one from the drop down list of the field. You can see the available content types and the associated file size in the "Content Types Overview" dialog. The dialog can be opened via the "Help/Content Types" menu.
Display Mode Yes The display mode for the entry. Possible values are:
  • Single Entry
    The entry is represented as single entry in the extended menu. The entry title in the workbook is used as entry title in the extended menu.
  • Multiple Entries
    This value can only be selected if the file behind the entry contains an own menu that is supported by "The!Cart Studio". The inner menu entries are extracted from the file during the export of the workbook. Only the titles of the inner menu entry, but not the title of the workbook entry, will appear in the extended menu.
Parameters Yes The parameters are relevant for entries with content type "ATR - Atari Disk Images". They contain the information required for modify the disk image content, so it can run from "The!Cart" instead of running from a disk drive. When you add a entry based on a disk image, the default parameters are automatically determined by "The!Cart Studio". You can change them manually in case the disk images does not work correctly with the defaults. To restore the defaults, add the disk image file again. For more information on the parameters see File Format and Content Type .
Start Bank Fixed Yes By default "The!Cart Studio" arranges the data for the entries of a workbook automatically. This is done based on a strategy that keeps the position of existing entries stable as long as there is enough free space. Together with the incremental flashing feature of the flashing software, this helps keeping the time require for updating "The!Cart" short. If you are a developer that creates software specifically for "The!Cart" or you even create other arbitrary binary exports with "The!Cart Studio", you may want to have control of the order and position of the entry data in the export. By setting the "Start Bank Fixed" checkbox, the corresponding field in the "Start Bank" becomes editable. "The!Cart Studio" will then used the specified start bank for the entry and will not rearrange the entry is space on the cartridge runs out.
Start Bank Yes The bank where the content for the entry is located. By default the start bank is determined and managed automatically by The!Cart. By setting the "Start Bank Fixed" checkbox, you make make this field editable and specify a fixed value manually.
Banks No The number of banks the entry will occupy on the cartridge.
Bank Assigned No This checkbox indicates the required banks for the entry could be assigned correctly. If there is not enough continuous space for the banks of the entry left on the cartridge, the "Banks Asigned" checkbox will not be set. Saving the workbook is possible in this case, but exporting the workbook is disabled. You can use the menu "Edit/Reassign Banks" to trigger a reordering of all entries to minimize gaps and free more space.

File Format and Content Type

Several file formats are supported when adding entries. In order to properly handle the ROM specific bank switching scheme, every entry must know its content type. For those file formats where the content type cannot be determined automatically, for example because there are multiple possible options, you have to select it in the "Content Type" column. The value help in the "Content Type" column is automatically filtered based on the file length and content. So it only offers the potentially matching content types. In additional some file formats even automatically converted before they are added to the workbook. Saving the workbook is possible at any time, even if there are entries with unknown content type. Only when the workbook is exported, the content type for all entries must be present. Here is a description of the supported file formats and their handling.

File Format Description
CAR Cartridge Image This is the recommended format to add ROM files. It is also by emulators. It contains a header with the exact type of the ROM file and a check sum to verify its integrity. This enables emulators to run the file without prompting the user for the exact content type upon each start. Similarly it enables "The!Cart Studio" to automatically determine the content type, so you don't have to choose something and the content type is not editable in this case.
BIN Cartridge Image
ROM Cartridge Image
This is the regular dump format for ROM file. It does no contain any information on the type of flash module was dumped from and the require bank switching to run it. Based on the size of the file, the "Content Type" column is restricted to those values that represent ROM of with the exact size of the file. For example a file with exactly 1 MB of data could be "Atarimax 1MB", "Mega Cart 1MB", "XEGS 1MB" or "Switchable XEGS 1MB". If you want to use your ROM files also in an emulator, it is advisable to convert the plain ROM file into a .CAR" files. All popular emulators have this function built in. This way you don't have to choose the correct flash module type on every start.
ATR Programming Images Collections created with the Maxflash Studio are sometimes available as "ATR Programming Images" instead of "BIN" or "ROM" cartridge images. They are bootable disk images which contain the program to flash the "Maxflash" cartridge directly from the Atari. They cannot be run or tested in an emulator. These programming images are recognized by "The!Cart Studio". When you add such a file as entry, it is first converted into a "CAR" cartridge image which is saved in the folder of the programming image. In case the ".car" file already exists in that folder, it will be overwritten. The new ".car" file is added to the workbook. This way you can even run and test the content of the "CAR" image in an emulator before flashing.
ATR Disk Images This is the standard Atari disk image format used in emulators. Many disk based programs that are available in this format can also be started from flash cartridges. But there are some natural limitations arising from the fact that loading the ATR images requires a simulation of the SIO routines that are located in ROM of the original Atari OS. For example the code for the simulation must be located in the RAM and may be overwritten when the loading from the ATR image starts. In addition the banks of the flash cartridge have to be activated during the SIO operation to load the data of the ATR image. As a consequence a program that uses a display list, graphics or interrupts in the cartridge memory area will run into problems. Also programs that try to write data to the disk will fail when run from an ATR simulation. For the simulation itself two approaches are used, Modified ATR Images and Modified Atari OS in RAM . It depends on the individual ATR file and its programs which of them will work best.

Modified ATR Images
This is the approach used by the "Extended Menu" of "The!Cart". When you add an ATR file directly to a workbook, the file is analyzed and all potential code locations that call the Atari OS SIO routines are identified. For disks that contain a known DOS (DOS 2.0S, DOS 2.5, MyDOS) and its "DOS.SYS" file, only the sectors that belong to that file are patched by default. For disks that contain the Bootmanager by Mike Langer, only the sectors or the Bootmanager are patched. For all other disks, the complete disk is scanned for usages of the SIO and that may potentially result in some false positives you have to removed manually from the parameters. The result of this analysis is stored in the "Parameters" column in the form "base=$100, $123=SIOV, $456=DSKINV". This column is hidden by default and can be made visible via the context menu of the table. When the workbook is exported for to the Atari, the calls at the found offsets are modified to point to the SIO simulation which as located at the address specified with the "base=$...." parameter. The advantage of this approach is that it works also on Atari 400 an Atari 800 machines that do not have RAM under the OS and for software that uses the RAM under the OS like for example "Turbo Basic XL 1.5" or "The Brundles". And by specifying the corresponding parameters it will work even for software that uses nonstandard SIO routines instead of the Atari OS SIO routines like for example "MyPicoDOS". The disadvantage of this approach is that it will not work with program where the code that calls the SIO vectors is packed or encrypted in the ATR. The following parameters are supported. Numbers are given in hexadecimal notation and are just example values. In the appendix Compatibility Patches you can find a list of known parameter combinations for programs that don't work with the default parameters.

  • base=$100
    This specified the base address for the SIO simulation code which is less than 256 bytes in size. The default base address is $400. If the ATR crashes while loading, it might be the case that the program overwrites this memory area. For example MyPicoDOS uses the memory location $400-$40f during loading. To solve this problem you can change the base address to $410 for example. Other good choices for base addresses are $100, $400, $480,$500,$600 and $100. Just try which one works for the specific program.
  • $123=SIOV
    The two bytes starting at offset $123 are changed to the start address of emulation code for the SIOV vector ($e459).
  • $123=<SIOV
    The byte at offset $123 is changed to the low byte of start address of emulation code for the SIOV vector ($e459).
  • $123=>SIOV
    The byte at offset $123 is changed to the high byte of start address of emulation code for the SIOV vector ($e459).
  • $123=DSKINV
    The two bytes starting at offset $123 are changed to the start address of emulation code for the DSKINV vector ($e453).
  • $123=<DSKINV
    The byte at offset $123 is changed to the low byte of start address of emulation code for the DSKINV vector ($e453).
  • $123=>DSKINV
    The byte at offset $123 is changed to the high byte of start address of emulation code for the DSKINV vector ($e453).
  • $123=SELECTEDITEMNUMBER
    The two bytes at offset $123 is changed to memory location which contains the item number of the selected menu entry. This can be used to modify inner menus to skip the selection and start the selected entry automatically. The item numbers are counted starting at zero. For example if you select the a menu entry which represents the 3rd item on a disk based ATR, the values in the memory location will be "2".

If you messed up the parameters somehow, you can simply add the ATR file again to the workbook and choose to overwrite the existing file in the workbook. In this case, the analysis is performed again and a default for the parameters is generated.

The SIO simulation in this approach supports both the read ("R", $52) and the status ("S", $53) command for "D1:". The status command set the 3 density bits of the "DVSTAT" status based on the density and size of the ATR. Using other disk units than "D1:" results in the error code "130 - Nonexistent Device". Using commands than "R" and "S" results in the error code "132 - Unknown command".

Modified Atari OS in RAM
This is the approach used by the Maxflash Menu or MegaCart Menu. The operating system is copied to the RAM under the OS ROM and is then modified to load the "disk sectors" from the flash cartridge instead of the real disk. The advantage of this approach is that it works equally for all software that uses the standard Atari OS SIO vectors, even if the SIO relevant code on the ATR is packed on encrypted. The disadvantage is that the approach will not work on machines like the Atari 400 or Atari 800 that do not have RAM under the OS like the Atari and not with programs that use the RAM under the OS themselves. You can use the Maxflash Studio or MegaCart Studio to create 128 KB, 1 MB or 2 MB collections with ATR disk images. Both studios come with proven emulation and provide several options to specify how the disk image shall be handled. You can then export the collection as BIN or CAR cartridge image and add it to the workbook.
Adding an ATR disk image Setting disk image options

COM Executable
EXE Executable
XEX Executable
This is the Atari DOS composite file format of executable files that can be loaded from a DOS. Many disk based programs that are available in this format can also be started from flash cartridges. To achieve this, typically a minimal DOS is copied to the RAM. The DOS is modified to load the "file segment" from the flash cartridge instead of the real disk. Of course this emulation has its limitations, for example for programs that use the RAM where the DOS or loader is located or perform real DOS operations like reading the directory or writing to disk. Currently you cannot add these files directly to a workbook. Instead you can use the Maxflash Studio or MegaCart Studio to create 128 KB, 1 MB or 2 MB collections with COM/EXE/XEX executables. Both studios come with proven emulation and provides several options to specify how the executable shall be handled. You can then export the collection as BIN or CAR cartridge image and add that to the workbook.
Adding an EXE executable Setting EXE executable options

Cartridge Database

The title and content type of many popular ROMs is also stored in the cartridge database. If you ROM is found in the database, the title and if known the content type are proposed. If no matching entry is found, the content type is set to "Unknown" and you have to select the appropriate content type manually before exporting the cartridge in and form.

The cartridge database is based on the list maintained by Tomasz Krasuski (Kr0tki) at AtariAge . It currently contains over 700 known titles and almost 700 known content types. The exact number are shown on the about dialog. You can support "The!Cart Studio" and improve the quality of the cartridge database by sending your own workbook file without (!) the ROMs to e-mail address .

Display Mode

Via the column "Display Mode" you can select how the entry is represented in the extended menu. Possible values are:

The following types and versions of inner menus are currently supported. For all of them, you can add the inner menu entries to the extended menu by choosing "Multiple Entries". When you add an entry to the workbook, the "Display Mode" will be set to "Multiple Entries" automatically by default. You can of course change the values if you don't want the inner menu entries to show up separately. By default you will start the inner menu when you select one of its entries in the extended menu. For some inner menus dedicated support has be implemented so selecting the inner menu entry even starts it directly.

File Type Menu Description
ROM Image Maxflash Studio Multiple entries is supported for a very large number of versions of Atari Maxflash Studio . Direct start is supported for the menus created witd the latest version of Maxflash Studio.
ROM Image MegaCart Studio Menu Multiple entries is supported for all official versions of MegaCart Studio . Direct start is supported for the menus created with the latest version of MegaCart Studio.
Disk Image Bootmanager by Mike Langer Multiple entries is supported for the 1996 version of the program, which is the only known version. Direct start is not supported. You can find the huge archive of disk images that use "Bootmanager" on the HomeSoft web site .
Disk Image MyPicoDOS Menu by Matthias Reichl (hias) Multiple entries is supported if there is a "PICONAME.TXT" configuration file on the disk. Direct start is not supported.

Previewing Workbooks

The menu entry "Tools/Preview" allows for a testing preview of the complete cartridge export and its menu in an emulator. For the preview, the workbook is exported as ".car" file with a fixed name into the temporary folder of the user. A previously existing preview is overwritten automatically. If no path to an emulator executable is configured in the options, "The!Cart Studio" tries to open the ."car" file with the associated default program of the operating system. If that fails, it will ask you to maintain the full path to the emulator, for example to "Altirra.exe" or "atari800.exe", in the options.

Exporting Workbooks

Export Formats

Export Format Description Supported Flash Types
BIN Cartridge Image Single plain binary cartridge file without header information with exactly the size specified by the flash type. Can be used directly to burn or flash the cartridge file to a physical cartridge with an arbitrary eprommer or flasher. You can also run the cartridge file in an emulator like Atari800, Atari800Win or Altirra. The emulator will try to detect the cartridge type from the ROM size and content. In case of doubt the emulator will prompt you for the correct cartridge type every time you open they cartridge file. Therefore using the "CAR Cartridge Image" export instead in recommended in this case. AtariMax 128k
AtariMax 1MB
The!Cart 128MB
User Defined
CAR Cartridge Image Single extended binary cartridge file with header information. Can be used directly run the cartridge file in an emulator like Atari800, Atari800Win or Altirra. The emulator will detect the cartridge type directly from the header, so you don't have to select in when opening the cartridge file. AtariMax 128k
AtariMax 1MB
The!Cart 128MB
User Defined
ATR Programming Image for AspeQt Single disk image in ATR format for use with AspeQt and the "The!Cart" flasher software on the Atari. The ATR file uses large sectors to achieve the maximum transmission speed and to store up to about 512 MB of information (65534 sectors of 8k size) in a single file. The file contains additional information to support incremental flashing to speed up flashing in case only parts of the project have been changed. In addition the file only contains the used sectors. Therefore this export format can also be used to program "The!Cart" cartridges of a size smaller than specified by the flash type, as long as the size does not exceed the physical size of the cartridge. The!Cart 128MB
User Defined
ATR Programming Images (16 MB) Multiple disk image in ATR format for use with SIO2USB, SIO2SD, SIO2PC or AspeQt and the "The!Cart" flasher software on the Atari. The ATR files uses normal double density sectors to be compatible with SIO2USB, SIO2SD and Atari DOS versions like MyDOS and SpartaDOS. The files contains additional information to support incremental flashing to speed up flashing in case only parts of the project have been changed. In addition the files only contain the used sectors. Therefore this export format can also be used to program "The!Cart" cartridges of a size smaller than specified by the flash type, as long as the size does not exceed the physical size of the cartridge. The!Cart 128MB
User Defined

The export always also generates a ".txt" index file with the title and origin of all menu entries. This way you can use the file system search of your operating system function to find games in exports. The index file also contains the information the for example "Amaurote 128 (130 XE)" is one of the menu entry that stees from the "Multiple Entries" setting for the workbook entry with the title "GAMES403" stored in "GAMES403.ATR"."

Printing Workbooks

You can print the content of the workbook including the list of entries via the menu entry "File/Print" (CTRL-P). The columns in the print output are the visible columns on the entries tab. Hence you can configure the columns you want to see as described in the section General Usage . For example you can make the column with the start bank visible, so you can use the simple menu to start entries and see the banks which are assigned to user space entries.
Print output

Programming Flash Cartridges

The!Cart

  1. Plug "The!Cart" in and power up your Atari.
  2. Press "ESC" to leave the extended menu and enter the simple menu with the black text screen.
  3. Press "F" to select the built-in flasher and then "RETURN" to start it.
  4. The flasher will automatically detect of the attached storage device support high-speed SIO.
  5. Press "1" for "Program Cartridge".
  6. If you use AspectQt and SIO2PC, insert the single large disk image created in the step Exporting Workbooks into the emulated drive "D1:" in AspeQt.
  7. If you use SIO2USB, SIO2SD or your alternative storage device, insert the the first of the nine 16 MB disk images created in the step Exporting Workbooks into the emulated drive "D1:" in AspeQt. If your storage device supports emulating multiple drives, you can insert the disk images 2..9 already in the subsequent virtual drives. This way you can leave the Atari along for a longer time during flashing.
  8. The flasher will prompt you with "drive number (1-15)"
  9. Press "1" and "RETURN" to start loading the data from disk.
  10. The flasher will load the header information and display the workbook title, date and number of used blocks. It will display if the export consists of multiple 16 MB images. In that case you can choose to search for further 16 MB disk images in all available drives.
  11. The flasher will prompt you with "perform incremental update (y/n)?"
  12. Press "y" to use incremental update.
  13. The flasher will prompt you with "start programming (y/n)?"
  14. Press "y" to start the actual flashing.
  15. The flasher will load the check sums, determine which differences exist between the current content of "The!Cart" and the content of the exported workbook. Only blocks that are different are loaded and updated.
  16. When done with programming, the flasher will prompt you with "Press any key to continue"
  17. Press "S" to start the cartridge.
  18. The flasher will prompt you with "Start Cartridge: 'E' for expert menu (y/e/n)?"
  19. Press "y" to start enter the updated extended menu.

In case you the built-in flasher can no longer be started for some reason, you can download the disk version. The disk version is available on Atari flashing software

Extended Menu

Pressing the RESET button on the "The!Cart" cartridge followed by pressing the RESET button on your Atari will take you to the menu. If the cartridge contains the simple menu only, holding OPTION while pressing RESET on the Atari disables the cartridge. If the cartridge contains the extended menu, holding OPTION while pressing RESET on the Atari starts the simple menu. This allows for starting the flasher and update the extended menu in case it does not work properly.
You can use the joystick or the keyboard to control the extended menu. You can narrow list by selecting the tab of a genre. The tab "All" always contains all entries. You can narrow down the list within a genre tab by typing any word or part of the title of the entry you are looking for. The search will find the entry no matter if something is in lower case or upper case. You can also use the joystick and the cursor keys to scroll though the result list. You can use the following controls: The most recent version of the CPLD logic for the "The!Cart" cartridge supports a configuration lock. The configuration lock ensures no software can unintentionally or maliciously change the contents of the "The!Cart" cartridge. If you have an early version of "The!Cart" cartridge, you can use a JTAG interface to update the CPLD logic . By default the configuration of "The!Cart" is locked when an entry is started. This means the configuration cannot be changed via software anymore until you press RESET button on the "The!Cart" cartridge. By pressing the "CONTROL" key as additional modifier when starting an entry, you can prevent the configuration lock. This can be useful when using software that is built to access the "The!Cart" cartridge in native mode, for example RAM disk drivers.

Advanced Topics

A number of advanced features of "The!Cart Studio" that are not so interesting for the regular user are also available.

Trouble Shooting

In case of problems, just post your question to the forums mentioned at the beginning of this document. Frequent mistakes are

For testing if your cartridge and the flasher work correctly, a number of test workbooks are available for download here . In case the computer does not even start with the cartridge inserted, you can try holding down the "OPTION" key during power-up to bypass the cartridge. The load the flasher program from disk instead and flash the cartridge again.

Appendix

Related Links

Compatibility Patches

This is a list of patches for programs that don't work out of the box with newer or non-standard Operating Systems or with the ATR loader of The!Cart. For them you can adapt the default parameters determined by "The!Cart" Studio. Just enter the solution listed in the "Parameters" column of the respective workbook entry the to patch the files during the export. Since the offsets specified here are specific for a given disk image, they may not work on other disk images.

Program File Issue Solution
Amaurote 128 (130 XE) GAME403.ATR Uses the memory starting at $480 during loading, hence overwriting the ATR loader if it uses that area. base=$0500, $011d=siov
Bounty Bob Str. Back! GAME049.ATR Uses the wrong PORTB value $8f when activating the OS ROM, causing extended RAM to become active in extended machines. The data from the empty extended RAM is copied under the OS and when pressing RESET, the empty data is copied over the actual program. Though the program seem to start correctly, it'll break later. base=$0400, $011d=siov, $122ed=$ff, $12318=$fe
M.U.L.E. GAMES067.ATR The crack intro uses the normally unused stack area starting at $114 and page 4 starting at $400. Therefore the base address for the ATR loader must be place at a different address. base=$0600, $011d=siov, $016a01=$ae, $016a02=selected_item_number, $016a04=$4c, $016a05=$8b, $016a06=$09
Popeye GAME009.ATR Uses and illegal entry point to OS-B, so it doesn't work on a standard Atari XL. base=$0400, $011d=siov, $1101a=$ea, $1101b=$ea, $1101c=$ea

Change History

2015-09-20

2015-08-08

2015-08-07 - Fujiama 2015 Edition

2015-04-26

2014-09-25

2014-09-24

2014-09-22

2014-09-16

2014-09-11

2014-08-04

2014-07-18

2014-07-12

2014-07-02

2014-04-03

2014-03-18

2014-03-02

2014-02-27

2014-02-22

2014-02-16

2014-02-13

2014-01-23

2014-01-17

2014-01-15

2014-01-14

2013-12-28

2013-12-26

2013-12-18

2013-12-13

2013-12-12

2013-12-11

2013-12-06

2013-12-05

2013-12-04

2013-12-02

2013-12-01

2013-11-26

2013-11-25

2013-11-04