WUDSN IDE update 1.1.0 released

You can use the menu entry "Help/Software updates/Available Software" to update from version 1.0.0 to 1.1.0. If you have problem during installation, uninstall version 1.0.0 first. Note that you have to do you compiler settings again since the data structure of the preferences was changed to support multiple compilers at once.

Features: See the tab "Features" on WUDSN IDE for screen shots

  • New content type and file association for "MADS Source File (*.asm)".
  • Dedicated syntax highlighting and content assist icon for pseudo opcodes, for example "BGE" and "BGE" in ATASM.
  • Configurable support for 16-bit opcodes of 65816.
  • New menu entry "Compiler Help" opens the compiler specific documentation if it is available.
  • Preliminary support for MADS and XASM, will be completed over time.
  • Extension mechanism to include additional compilers via Eclipse extension points and improve them step by step.
  • Download hyperlink labels in the preferences to download the compilers and emulator to simplify installation.
  • Default extensions for path browsing in the preferences is now "*.exe" on windows, and "*.*" on all other operation systems including Mac OS X.
  • Build-in read-only hex editor with support for Atari COM files and file segment outline.
  • Choice via popup menu for binary includes to open the file with the build in hex editor, the default Eclipse editor (e.g. a text editor), system editor (e.g. an emulator or a paint program).
  • German localization for all Eclipse plugin texts. The original compiler messages are not translated.

Fixes:

  • ResourceException in German installations fixed.
  • Syntax highlighting settings are now correctly restore upon "Restore Defaults".

Site Update:

  • Features section updated with the latest features and screen shots.
  • Download for single archive containing all supported Atari compilers including the Mac OS X versions provided by Spookt.
  • See the tab Features on WUDSN IDE for the new installation description.
    • ATASM 1.06, Windows and MaxOS X.
    • MADS 1.8.5, Windows and MaxOS X (version 1.8.4).
    • XASM 3.0.1, Windows.